I just lost a days of mining.

Encounter a problem related to the pool or have a request for a feature? Post your issue here and we will help you out.
User avatar
Doggo
Posts: 7
Joined: Mon Jan 04, 2021 6:50 pm

I just lost a days of mining.

Post by Doggo » Mon Jan 04, 2021 6:54 pm

I just noticed that my miner that was working on a ethereum pplns pool over the last few days just got kicked off while ethereum was under some sort of errors, then once it let me back on, it reset days of work. which was about 30% of the 2 eth block. I wanna know whats going on?
User avatar
Steve Sokolowski
Posts: 4211
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: I just lost a days of mining.

Post by Steve Sokolowski » Mon Jan 04, 2021 9:50 pm

Doggo wrote:
Mon Jan 04, 2021 6:54 pm
I just noticed that my miner that was working on a ethereum pplns pool over the last few days just got kicked off while ethereum was under some sort of errors, then once it let me back on, it reset days of work. which was about 30% of the 2 eth block. I wanna know whats going on?
I'm not aware of any issues with ETH that were persistent over several days.

This seems like it could be related to your specific configuration. Please submit a support ticket with your username and we'll be glad to assist!
User avatar
Doggo
Posts: 7
Joined: Mon Jan 04, 2021 6:50 pm

Re: I just lost a days of mining.

Post by Doggo » Mon Jan 04, 2021 10:53 pm

It wasn't a persistent issue, this only happened after I was unable to mine ethereum today.
User avatar
Steve Sokolowski
Posts: 4211
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: I just lost a days of mining.

Post by Steve Sokolowski » Tue Jan 05, 2021 11:21 am

This issue was also reported by other customers, but it wasn't caused by yesterday's system downtime. I assigned it to Steven and Chris for research.

This is a complex issue that is expected to require significant investigation, so I apologize for how long it is expected to take to get an answer for you.
User avatar
Doggo
Posts: 7
Joined: Mon Jan 04, 2021 6:50 pm

Re: I just lost a days of mining.

Post by Doggo » Wed Jan 06, 2021 6:28 pm

Alright, thanks. I'm all open ears if you guys find anything.
User avatar
Steve Sokolowski
Posts: 4211
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: I just lost a days of mining.

Post by Steve Sokolowski » Thu Jan 07, 2021 2:42 pm

This issue has been resolved, and Chris released the changes.

It turns out that the problem was that the Postgres database doesn't enforce NULLs in unique constraints, so the system kept inserting repeated "first round" PPLNS rows every time it was restarted. We restarted the system earlier in the week, and while the restart didn't cause the problem, it was the first restart since PPLNS mining has been widely used.

Chris added together all of the rows and mining has resumed as normal. No money was lost.
nyspsycho1
Posts: 3
Joined: Mon Jan 25, 2021 6:28 pm

Re: I just lost a days of mining.

Post by nyspsycho1 » Mon Jan 25, 2021 10:07 pm

the same thing just happened to me with bitcoin and z cash .5 btc and 1.4 zcash . could i get some help
User avatar
Steve Sokolowski
Posts: 4211
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: I just lost a days of mining.

Post by Steve Sokolowski » Mon Jan 25, 2021 10:14 pm

nyspsycho1 wrote:
Mon Jan 25, 2021 10:07 pm
the same thing just happened to me with bitcoin and z cash .5 btc and 1.4 zcash . could i get some help
We're not aware of any widespread issues, but we'll be glad to look at your account to see what could have happened. Feel free to submit a support ticket with your username and we'll be glad to help!
nyspsycho1
Posts: 3
Joined: Mon Jan 25, 2021 6:28 pm

Re: I just lost a days of mining.

Post by nyspsycho1 » Wed Feb 17, 2021 8:25 pm

i wanted to wait a bit to make sure it wasnt going to pop into my accout . but still nothing trying to figure out how to send you a message. i had my miners going for almost a month then they all revd up at once i looked at my records and it was gone...... i also happend to have a few screen shots if interested thanks for getting back so fast.
User avatar
Steve Sokolowski
Posts: 4211
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: I just lost a days of mining.

Post by Steve Sokolowski » Thu Feb 18, 2021 11:44 am

nyspsycho1 wrote:
Wed Feb 17, 2021 8:25 pm
i wanted to wait a bit to make sure it wasnt going to pop into my accout . but still nothing trying to figure out how to send you a message. i had my miners going for almost a month then they all revd up at once i looked at my records and it was gone...... i also happend to have a few screen shots if interested thanks for getting back so fast.
Please submit a support ticket about this issue.

Chris resolved a PPLNS mining issue involving old rows being removed a while ago, but your report suggests the issue has returned. He will gather information about your account and work with you once you submit a ticket.
Post Reply