Ethash shares issue resolved

News updates about the Prohashing pool
Post Reply
User avatar
Steve Sokolowski
Posts: 4469
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Ethash shares issue resolved

Post by Steve Sokolowski » Sun Jul 25, 2021 8:43 am

On Friday evening, Chris adjusted the ethash minimum difficulty so that customers with weaker equipment could submit shares more frequently. The change revealed an issue involving floating-point arithmetic. Since miner difficulties are stored as floating-point numbers, multiplying and dividing them by 2 repeatedly added small errors until a check in the mining server that prevents miners from using non-powers of 2 triggered. The error occurred for customers who had miners with a hashrate that was just between two low difficulties, where the mining server would repeatedly raise and lower the assigned difficulty.

Chris temporarily resolved the issue by raising the minimum difficulty back to its original value, and the system returned to normal yesterday.

Additionally, we found that the code that sets initial difficulties failed when the power of 2 was less than zero, and would assign a difficulty of 1. We fixed that bug, as well as the original bug, in the latest version. After Vance returns on Monday and approves the code, we will release the changes and re-lower the difficulty so that less powerful miners can submit more shares.

Finally, we discovered that some customers on the forums, mostly new customers with few posts, lied about the error by reporting issues that weren't possible, such as encountering this problem the day before Chris lowered the difficulty. We confirmed that there were no instances of the error then, and therefore the customers who lied on the forums have been warned and their complaints deleted. As the "trivially provable" rule states, customers are required to make at least a minimal effort to not make patently false statements.
-MaVerick-
Posts: 67
Joined: Wed May 12, 2021 3:12 pm

Re: Ethash shares issue resolved

Post by -MaVerick- » Sun Jul 25, 2021 12:52 pm

Win10 471.11, RTX3060 on miniZ, GTX1060 6GB on GMiner, not a single bad share for at least 8h since I rebooted my PC. Didn't see any of them in the nightshift stats neither. Works for me.
Steve Sokolowski wrote: Sun Jul 25, 2021 8:43 am Finally, we discovered that some customers on the forums, mostly new customers with few posts, lied about the error by reporting issues that weren't possible, such as encountering this problem the day before Chris lowered the difficulty. We confirmed that there were no instances of the error then, and therefore the customers who lied on the forums have been warned and their complaints deleted. As the "trivially provable" rule states, customers are required to make at least a minimal effort to not make patently false statements.
I'm astonished by the calmnes you guys keep when dealing with "those" guys. Some of them are really something, the shoutbox can be entertaining.
Post Reply