Not getting credited and payed for blocks found

Discuss issues with mining rigs and connectivity issues with experienced Prohashing miners.
JiveTonto
Posts: 106
Joined: Thu Mar 05, 2015 1:49 pm

Re: Not getting credited and payed for blocks found

Post by JiveTonto » Tue Jan 09, 2018 3:35 am

[quote="Steve Sokolowski"][/quote]


ok start at block 1139895 in the block explorer
then move to block 1139896, according to the block explorer it took 2 hours..............according to the recorded stats in my worker log on your site it took less than 4 minites



now in the block explorer look at the timestamp of block 1139896 and start going next /next /next /next and so on .............a whole lot of blocks found within a few seconds and if you continue youll see the pattern go into minutes


now about what your saying causing the orphans,I call rubbish i mine this coin solo and on other pools and have less than a .1% orphan rate at any difficulty,whats causing the orphans is what i explained in one of your "Status of the day" updates about your daemon or server and issuing bad blocks e.g same block different workunit even tho its had a summited the found block it gives back a bad workunit for that same found block hence resulting in the miner submitting (again) for that same block giving an orphan



reason im using those block numbers and not time is because thats what ive pulled from the worker log you provide,with the block explorer and block numbers you can get timestamps and see gaps between found blocks...........which clearly dont match what your reporting in the workerllog
User avatar
Steve Sokolowski
Posts: 4014
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: Not getting credited and payed for blocks found

Post by Steve Sokolowski » Tue Jan 09, 2018 8:17 am

JiveTonto wrote:
Steve Sokolowski wrote:

ok start at block 1139895 in the block explorer
then move to block 1139896, according to the block explorer it took 2 hours..............according to the recorded stats in my worker log on your site it took less than 4 minites



now in the block explorer look at the timestamp of block 1139896 and start going next /next /next /next and so on .............a whole lot of blocks found within a few seconds and if you continue youll see the pattern go into minutes


now about what your saying causing the orphans,I call rubbish i mine this coin solo and on other pools and have less than a .1% orphan rate at any difficulty,whats causing the orphans is what i explained in one of your "Status of the day" updates about your daemon or server and issuing bad blocks e.g same block different workunit even tho its had a summited the found block it gives back a bad workunit for that same found block hence resulting in the miner submitting (again) for that same block giving an orphan



reason im using those block numbers and not time is because thats what ive pulled from the worker log you provide,with the block explorer and block numbers you can get timestamps and see gaps between found blocks...........which clearly dont match what your reporting in the workerllog
I agree - we know that this is one of the problems you reported. You might remember that there were three separate issues. The first, which we fixed, involved the inconsistency of the number of found blocks displayed in mining software compared to the number that were actually able to be submitted. The second is the one you reported here, where some blockchains don't advance for an unknown reason.

We have yet to be able to determine the cause of this problem, or even if the problem is what you've suggested it is. I'll keep you updated as soon as we learn more.
spauk
Posts: 151
Joined: Wed Apr 27, 2016 7:33 pm

Re: Not getting credited and payed for blocks found

Post by spauk » Tue Jan 09, 2018 12:38 pm

some coins are just bad to solo mine with too much hashrate, sorry to burst your bubble
spauk
Posts: 151
Joined: Wed Apr 27, 2016 7:33 pm

Re: Not getting credited and payed for blocks found

Post by spauk » Wed Feb 07, 2018 5:18 am

i've noticed recently when watching some of my miners they found a block on pps dynamic coin, and the found blocks section on prohashing earnings page still doesn't show up with all the found blocks. but i think all the shares were credited fine, so it's some kind of display error or the mining server still showing found blocks as accepted to the miners even though they get orphaned. it's most likely donation coin or some other low difficulty coin (under 1) i didn't see which coin it was mining but i saw the network difficulty and it found a couple blocks in a row
User avatar
Steve Sokolowski
Posts: 4014
Joined: Wed Aug 27, 2014 3:27 pm
Location: State College, PA

Re: Not getting credited and payed for blocks found

Post by Steve Sokolowski » Wed Feb 07, 2018 9:40 am

spauk wrote:i've noticed recently when watching some of my miners they found a block on pps dynamic coin, and the found blocks section on prohashing earnings page still doesn't show up with all the found blocks. but i think all the shares were credited fine, so it's some kind of display error or the mining server still showing found blocks as accepted to the miners even though they get orphaned. it's most likely donation coin or some other low difficulty coin (under 1) i didn't see which coin it was mining but i saw the network difficulty and it found a couple blocks in a row
This used to be a problem in December, and we thought we had fixed it, but it looks like we're back to square one on it.

It would be great if you start keeping detailed logs of the miners, and then submit them when the problem happens again. Specifically, we need the exact time the blocks are found but not displayed, and the name of the worker that is having the issue.
Post Reply